Artigos‎ > ‎Android‎ > ‎Motorola Atrix WebTop‎ > ‎

x2go client no Motorola Atrix WebTop


Primeiramente gostaria de salientar que não sou o autor principal do conteúdo deste artigo. A minha intenção é de mostrar o que outros autores tem realizado (referenciando links para o conteúdo original) neste blog até como um guia pessoal para uso próprio e ainda compartilhar minhas anotações e pequenas modificações que realizo no conteúdo, desejando que possa ajudar mais alguém em algum lugar.
First and foremost, I take no credit for any of this post’s content. I am really just taking what others have done (which I have links to bellow) and am putting it on my blog for a personal reference and hopefully the small changes that I made to their guides will help someone somewhere.


Compilar x2go do código fonte no webtop atrix (ubuntu jaunty armel):

sudo apt-get install build-essential git-core qt4-dev-tools libmpfr1ldbl nxproxy

link: http://www.nomachine.com/sources.php
nxcomp
nxproxy

link: http://www.x2go.org/doku.php/download:source-tarballs
link: http://www.x2go.org/doku.php/wiki:development:git
mkdir -p ~/x2go
cd ~/x2go
git clone git://code.x2go.org/x2goclient.git
cd ~/x2go/x2goclient
sudo make && sudo make install

Esta dando um erro que precisa ser solucionado... Não funcionou a compilação.

Uma outra tentativa é utilizar os pacotes compilados para o ubuntu precise (também não funcionou):
mkdir -p ~/x2go
cd ~/x2go

wget http://launchpadlibrarian.net/96028086/multiarch-support_2.13-20ubuntu5.1_armel.deb
sudo /usr/bin/dpkg -i --root=/osh multiarch-support_2.13-20ubuntu5.1_armel.deb
wget http://launchpadlibrarian.net/92449824/libssl1.0.0_1.0.0e-2ubuntu4.2_armel.deb
sudo /usr/bin/dpkg -i --root=/osh libssl1.0.0_1.0.0e-2ubuntu4.2_armel.deb
wget http://launchpadlibrarian.net/81152314/libssh-4_0.5.2-1_armel.deb
sudo /usr/bin/dpkg -i --root=/osh libssh-4_0.5.2-1_armel.deb
wget -O libstdc++6_4.6.3-1ubuntu3_armel.deb http://launchpadlibrarian.net/96089204/libstdc%2B%2B6_4.6.3-1ubuntu3_armel.deb
sudo /usr/bin/dpkg -i --root=/osh libstdc++6_4.6.3-1ubuntu3_armel.deb

wget http://launchpadlibrarian.net/92262865/x2goclient_3.99.0.5-1_armel.deb
sudo /usr/bin/dpkg -i --root=/osh x2goclient_3.99.0.5-1_armel.deb

wget http://sft.if.usp.br/debian/pool/main/x/x2goclient/x2goclient_3.99.1.1-1_armel.deb
sudo /usr/bin/dpkg -i --root=/osh x2goclient_3.99.1.1-1_armel.deb
Ultima tentativa é utilizando o repositorio abaixo do link: http://www.x2go.org/doku.php/wiki:x2go-repository-debian
sudo apt-key adv --recv-keys --keyserver keys.gnupg.net E1F958385BFE2B6E
sudo tee /etc/apt/sources.list.d/x2go.list <<EOF
# X2Go Repository deb http://packages.x2go.org/debian squeeze main # X2Go Repository (sources) deb-src http://packages.x2go.org/debian squeeze main
EOF
sudo apt-get update

Veja os pacotes disponiveis com: 
apt-cache search x2go

sudo apt-get install dpkg-dev x2go-keyring
sudo apt-get -b source x2goclient

Como não deu certo voce pode desfazer o repositorio:
sudo rm /etc/apt/sources.list.d/x2go.list


Mais uma tentativa:
http://www.x2go.org/doku.php/download:source-tarballs

mkdir -p ~/x2go
cd ~/x2go
wget http://code.x2go.org/releases/source/x2goclient/pre-git/x2goclient_2.0.1-12.tar.gz
tar -xvzf x2goclient_2.0.1-12.tar.gz cd x2goclient-2.0.1
qmake
make && sudo make install

Mais uma tentativa:
link:  http://www.cyberciti.biz/faq/rebuilding-ubuntu-debian-linux-binary-package/#comments 

mkdir -p ~/x2go cd ~/x2go
sudo apt-get install build-essential fakeroot dpkg-dev
sudo apt-get install debhelper libldap2-dev libssh-dev libxpm-dev doxygen man2html
Pacotes que apresentaram problemas antes do force:
sudo apt-get install libcups2=1.3.9-17ubuntu3.9 libgnutls26=2.4.2-6ubuntu0.1 libgnutls-dev libcups2-dev


git clone git://code.x2go.org/x2goclient.git
cd ~/x2go/x2goclient
dpkg-buildpackage -rfakeroot -b 

ou
sudo apt-get source x2goclient
sudo apt-get build-dep x2goclient
sudo dpkg-source -x x2goclient.dsc
dpkg-buildpackage -rfakeroot -b
sudo dpkg -i ../x2goclient.deb


O URL específico do gadget não foi encontrado



Comments